News:

Author Topic: WMI Provider Host, how to disable it?  (Read 527 times)

0 Members and 1 Guest are viewing this topic.

Ducky123

  • I like cute things!
  • Member+
  • *
  • Posts: 7407
    • View Profile
WMI Provider Host, how to disable it?
« on: August 11, 2019, 09:30:13 AM »
I'm having this little problem with a service called WMI Provider Host. It's sometimes eating up to 10% of my cpu power even though I have disabled the service as suggested by many online articles about this program. Does anyone have any suggestions what I could do to fight this nuisance? cpu can be a bit of a bottleneck on my system so it'd really help me make this laptop a little faster.

[attachments: one is showing a glimpse at my task-manager showing the extensive cpu usage, the other is proof that I disabled the service (deactiviert = disabled, sorry I didn't want to convert my whole system to english for this :P)]
mostly inactive due to exam preparation. Includes my creative work in particular which is entirely on hiatus. Hit me on discord if you need something, I'm more active there :)

ImpracticalDino

  • Member+
  • *
  • Posts: 3907
  • A tryhard on hiatus.
    • View Profile
Re: WMI Provider Host, how to disable it?
« Reply #1 on: August 11, 2019, 09:45:32 PM »
Well, I don't have a problem with that process. It always uses 0% CPU on the computer I use. Maybe this website could help with your problem.

I had a similar issue to your problem where I disable Windows Update via services because it always used up so much CPU in my system, but I notice that it appears again in Task Manager. I check the services again, and guess what...Windows Update went from Disabled to Manual (Trigger Start). I found out that this service actually re-enables itself after a certain amount of time. I don't bother reverting the setting anymore since Windows Update doesn't use a lot of CPU anymore or interrupt my current session with updates.

So yeah, weird that the service is running despite showing itself as disabled in the services window.

ImpracticalDino

  • Member+
  • *
  • Posts: 3907
  • A tryhard on hiatus.
    • View Profile
Re: WMI Provider Host, how to disable it?
« Reply #2 on: September 18, 2019, 07:49:16 PM »
This thread is pretty old, but I assume your problem has been solved at this point?